PHP: Hypertext Preprocessor, also known as PHP, is a popular coding language, which can be used to set up dynamic sites with interactive features like discussion forums, school websites or community portals. In comparison to static HTML-based websites, a PHP-driven website can serve unique content to each user under the exact same URL. As PHP-based web applications can be managed via one Control Panel tool, which you can sign into using any web browser, you will not need to have any web development expertise or past experience in order to run a PHP-driven site. The fact that 100s of millions of websites all over the world are based on PHP is an indication of the popularity and the ease of use of the language. You only need to verify if the server where you host your site supports the same exact PHP version as the one that you used while developing the website.

PHP 4, PHP 5 and PHP 7 Support in Cloud Hosting

Our cloud hosting servers support several PHP versions, which goes to say that your websites will run without any problem no matter if your scripts are out of date. We acknowledge the fact that an old site doesn’t necessarily imply an insecure one as you may have done a lot of mods to its source code. This is the reason why we support PHP 4, PHP 5 and PHP 7 and you can select which version will be active for your shared hosting account. The version can be changed with one click of the mouse via your Hepsia hosting Control Panel and the update will take effect instantly. If you want to run both newer and older scripts, there’s even a possibility to use a different version of PHP for each domain name of yours simultaneously.

PHP 4, PHP 5 and PHP 7 Support in Semi-dedicated Hosting

If you’ve got a site created using a previous version of PHP and you’ve committed time and efforts towards setting it up, patching security breaches and embedding page content, you will need to find a web hosting service that can support it, as the vast majority of hosting providers these days support only the most recently introduced version of PHP and remove the previous ones. We, however, have decided to allow you to select the exact version that your very own sites need. Our Linux semi-dedicated services support PHP 4, PHP 5 and PHP 7, which goes to say that you will be able to run both newer and older scripts without forfeiting any manual modifications or frittering away time and efforts struggling to make your websites compatible with the web hosting platform. You can change the current version from the Hepsia Control Panel and such a change will apply to the entire semi-dedicated account, but you’ll also be able to choose a different version of PHP for each single site that you host in your account using an .htaccess file.